What do I need to use the I-BUS app?

From I-BUS App Wiki
Jump to navigation Jump to search
  • An Android device (radio/tablet/mobile phone) with a fully functional USB port. (i.e. it have to recognize e.g. an USB stick as data medium)

We only recommend to use one of the tested Android radios with PX5 or PX6 processor.

Some users own radios with hardware differing from the above recommendation, which do not provide drivers for the Resler interface and due this could not recognize it. Thus we can NOT guarantee that it will work with ANY Android device, but with all recommended radios. We are not liable if the Android device cannot recognize the interface!

  • Android up on version 4.4.4, better 5.11


Why do we only recommend the "Resler-USB-Interface" and no other interface?
→ The (often red-brown) CAN BUS Box supplied with the radio is not a resler interface and not a replacement for it. It is only needed for the MFL keys functions, key illumination and reverse gear detection.

  • The I-BUS App itself, installed on the device. (Note: Download contains a *.zip file, which must be unpacked before installation!)
  • Purchase of a license by specifying of the VIN of the vehicle to use the I-BUS App with all functions. To the selection stand:
    • License for BC, coding and comfort functions [EUR 22.00].
    • License to control the original DSP power amplifier (BMW E38/E39/E53/E83 only) [EUR 23.00]
    • Combined licence [EUR 40,00]
    • VIN-SWAP (license modification) [EUR 5.00]

Overview What licenses are available for the I-BUS App and what functions do they provide?
(Prices as of 01.01.2019)

  • The license is - even without feedback - usually 'unlocked within 1h. After that the app only has to be activated. A VIN change or the DSP upgrade may take up to 24 hours.

→ Open the app, touch the three dots in the upper right corner and tap on "activate". In the next window tap on the big button "unlock", for this the device must be online.


without click


1 up on App version v2.0 there may be malfunctions on radio with Android 5.1 and older. Only version 1.5.5.2 can be used here, but it is not maintained/updated any further.